Error Msg "No Python engine was created"

Solved bugs are moved into this topic...

Postby Manimal » 17.10.2016 15:47

Hi guys.

You have a amazing piece of software here. I loved it.
All the options, the configurations that are possible... Really good!

But I have to raise 2 (two) little issues in installation setup:

1) The missing DLL not found in original package: api-ms-win-crt-runtime-l1-1-0.dll (SOLVED- copyed from another place)
2) THe error message above "No Python engine was created". I can't use any option about comments or addons manager...
Can you help me about that?

Thx in advance.
Manimal
 
Posts: 3
Joined: 17.10.2016 12:48

Postby MarianD » 19.11.2016 18:07

The solution is as simple as deleting all old files

  • python3x.zip
  • python3x.dll
(where x < 5) from the Synwrite installation folder.

Don't delete the newest python35.zip and python35.dll!
MarianD
 
Posts: 12
Joined: 30.03.2015 16:38

Postby Manimal » 20.11.2016 12:34

Hi MarianD.

Thanks for your answer, but I only have the original files from installation.

There is no other python3?.zip or dll in my installation folder (C:\SynWrite\) or any other folder. I don't work with Python at all.

Take a look http://prntscr.com/d9k2z4

Thanks
Manimal
 
Posts: 3
Joined: 17.10.2016 12:48

Postby MarianD » 20.11.2016 13:19

In your Synwrite folder is an other suspicious library:

  • api-mswin-crt-runtime-I1-0-0.dll
which may be the cause of your problem.
Try renaming it (because it is safer as just deleting it).

(Synwrite is dependent of Python - in spite if you don't use it.)
MarianD
 
Posts: 12
Joined: 30.03.2015 16:38

Postby Alexey » 20.11.2016 15:59

These problems are cozed by Python DLL. Download Cudatext with Python 3.4 for Win-xp. https://sourceforge.net/projects/cudate ... 386/files/
If you use Synwrite, copy files for Python 3.4 from Cudatext zip file
and delete Py 3.5 files-
*.dll
*.zip
DLLs\
Alexey
 
Posts: 1129
Joined: 05.10.2012 22:10

Postby Manimal » 21.11.2016 10:26

Hi, MarianD.

Like I said in the first post, the api-mswin-crt-runtime-I1-0-0.dll file is needed for running SynWrite.
If I erase/rename/remove this file, the SynWrite doesn't work like this msg:

http://prnt.sc/d9wovg

Translating: The program can't be started because is missing api-mswin-crt-runtime-I1-0-0.dll. Try to reinstall....
Thanks anyway.

@Alexey:
With your tips, it's working like a charm now.
Thanks a lot!

PS: Even I was able to remove the file api-mswin-crt-runtime-I1-0-0.dll with the Python3.4 files!

Problem solved!
Manimal
 
Posts: 3
Joined: 17.10.2016 12:48


Return to Issues solved

Who is online

Users browsing this forum: No registered users and 1 guest

cron